Logo

Erlang、RabbitMQ下载与安装教程(windows超详细)

photo

2024年04月11日

目录

安装Erlang

1.首先安装RabbitMQ需要安装Erlang环境 

2.点击下载好的.exe文件进行傻瓜式安装,一直next即可

3.配置Erlang环境变量

安装RabbitMQ

 1.给出RabbitMQ官网下载址:Installing on Windows — RabbitMQ,找到

 2.配置RabbitMQ环境变量,过程跟配置Erlang相似

 3.安装管理工具RabbitMQ-Plugins,进入sbin文件下,打开命令窗口输入

 4.只要第二部是成功的,安装好管理工具后,进入C:\Program Files\RabbitMQ Server\rabbitmq_server-3.12.10\sbin ,点击rabbit_server.bat,启动rabbitMQ

 5.最后输入http://localhost:15672/(默认账号:guest,密码:guest)就能进入RabbitMQ管理界面

遇到的问题及解决 

1.安装管理工具RabbitMQ-Plugins,出现下面场景

2.登录RabbitMQ页面,rabbitmq看不到exchanges 和queues


Erlang 、RabbitMQ (windows安装 exe安装版本超详细教程)

一切为本人亲自操作查阅资料进行安装,以及遇到的问题和解决的有效方法,欢迎各位阅读我的博客,然后有效的解决各位的问题(如果我遇到过的话,哈哈!)

前提:注意参考Erlang和RabbitMQ的版本对应关系

RabbitMQ Erlang Version Requirements — RabbitMQ

血泪:不要后来才去查看两者的版本对应关系,导致Erlang或者RabbitMQ重新下载

安装Erlang

1.首先安装RabbitMQ需要安装Erlang环境 

1.给出Erlang官网下载地址:Downloads – Erlang/OTP

亦或者 Index of /download/ (erlang.org)  (我这里能够直接打开,不确定其他使用者怎么样)

 然后下滑找到你所要下载的版本,例如otp win64 26.1.exe。

注意:官网下载速度令人怀疑人生,时间充足,就慢慢下载或者找个网络好的地方,时间紧凑,那就找人给你已经下载好的压缩包吧

2.点击下载好的.exe文件进行傻瓜式安装,一直next即可

注意:中途下载时如果你不特定修改路径的话,还是记录一下你的下载安装路径在哪里,方便后续查看

3.配置Erlang环境变量

1.在搜索框里输入编辑系统环境变量,点开它得到

2.打开环境变量,得到

3. 在系统环境变量里面,创建

注意:变量名一定要写成ERLANG_HOME,变量值就是你的Erlang的安装路径 

 注意:还需要在系统变量中选中Path进行编辑,新建一个%ERLANG_HOME%\bin

 4.打开命令窗口,输入erl或者erl -version()验证环境是否配置成功(出现以下版本号即成功,显示不是内部命令则环境变量配置失败)

安装RabbitMQ

1.给出RabbitMQ官网下载址:Installing on Windows — RabbitMQ,找到

 注意:点击下载的时候没反应,可能是网络延迟的问题,尝试多点几次,不要迷茫,就是这里(我就是点了几次没反应以为这里下载不了,又去找其他位置,兜兜转转又回到这里)

 2.配置RabbitMQ环境变量,过程跟配置Erlang相似

注意:这里一个rabbitmq是sbin,一个erlang是bin 

3.安装管理工具RabbitMQ-Plugins,进入sbin文件下,打开命令窗口输入

rabbitmq-plugins enable rabbitmq_management

 注意:出现上图表示成功,出现下图表示失败,需要查找问题解决它,并且只有出现上图才表示成功,其他类似的都是错的

4.只要第二部是成功的,安装好管理工具后,进入C:\Program Files\RabbitMQ Server\rabbitmq_server-3.12.10\sbin ,点击rabbit_server.bat,启动rabbitMQ

血泪: 不要乱相信一些博客,一定不要重启电脑,重新输入命令安装(我尝试了,然后重新安装管理工具RabbitMQ-Plugins直接失败,启动rabbitMQ直接闪退)

 5.最后输入http://localhost:15672/(默认账号:guest,密码:guest)就能进入RabbitMQ管理界面

遇到的问题及解决 

1.安装管理工具RabbitMQ-Plugins,出现下面场景

我的解决方法:

 1.直接卸载rabbitmq_server-3.12.10,(确定自己是从正规途径卸载的,然后将它的残余也删除干净,重新下载

2.修改enabled_plugins文件,其通常与配置文件一起位于节点数据目录或/etc下,我的是在C:\Users\Administrator\AppData\Roaming\RabbitMQ\enabled_plugins,可以直接删掉该文件,再重新安装插件 (本人亲测有效,这个路径应该能够直接找到,只有你这个是错的,正确的话就不存在了)

3.rabbitmq-plugins disable rabbitmq_management

   rabbitmq-plugins enable rabbitmq_management

这两个命令我也使用过,但还是在下载安装插件时,报上面图片的错误

2.登录RabbitMQ页面,rabbitmq看不到exchanges 和queues

问题描述:我们在“交换”页面中收到以下错误消息:

ReferenceError: display is not defined ReferenceError: display is not defined at Array.process (eval at compile (https://URL/js/ejs-1.0.min.js:1:6654), :11:67) at EJS.render (https://URL/js/eja-1.0.min.js:1:1885) at format (https://URL/js/main.js:1176:21) at https://URL/js/main.js:463:24 at with_reqs (https://URL/js/main.js:1158:9) at https://URL/js/main.js:1154:17 at req.onreadystatechange (https://URL/js/main.js:1235:17)

我们在“队列”页面中收到以下错误消息:

ReferenceError: ac is not defined ReferenceError: ac is not defined at Array.process (eval at compile (http://localhost:15672/js/ejs-1.0.min.js:1:6654), :229:2) at EJS.render (http://localhost:15672/js/ejs-1.0.min.js:1:1885) at format (http://localhost:15672/js/main.js:1176:21) at http://localhost:15672/js/main.js:463:24 at with_reqs (http://localhost:15672/js/main.js:1158:9) at http://localhost:15672/js/main.js:1154:17 at req.onreadystatechange (http://localhost:15672/js/main.js:1235:17)

我的解决方法:非常简单清除缓存并重新加载

  • 正常重新加载 (Ctrl + R): 正常刷新,使用缓存数据。
  • 硬性重新加载 (Ctrl + Shift + R):强制浏览器重新下载并加载内容。资源有可能来自于缓存的版本。
  • 清空缓存并硬性重新加载:完全清除页面的缓存并重新下载所有内容。

我们采用硬性重新加载,本人亲测有效,直接解决。 

本文为原创文章,请注意保留出处!

一.使用背景我们在项目中使用的过程中很多时候需要转pdf,但是有很多控件不行,或者格式不对,所以很...Excel转PDF基于Microsoft.Office.Interop.Excel

热门文章

修复群晖Synology Drive client右键菜单缺失问题 本教程主要解决windows10右键菜单中没有SynologyDrive菜单的问题,整体思路是找到...修复群晖SynologyDriveclient右键菜单缺失问题 作者:Pastore Antonio
1848 浏览量
docker如何查看一个镜像内部的目录结构及其内部都有哪些文件 前言:有时候我们会在docker上下载一个镜像,或者是上传一个镜像到docker上,甚至有时候就是在...docker如何查看一个镜像内部的目录结构及其内部都有哪些文件 作者:Pastore Antonio
1822 浏览量
Adobe Acrobat Pro 激活 这里记录了一些AdobeAcrobat的激活教程和组件。浏览量:1,705 作者:Pastore Antonio
1550 浏览量
configure: error: Package requirements (oniguruma) were not met configure:error:Packagerequirements(oniguruma)...configure:error:Packagerequirements(oniguruma)werenotmet 作者:Pastore Antonio
1548 浏览量
追寻日出,找回自己 为什么我要去追寻日出?其实我是一个很懒的人,每次都起不来,直到有一次我在租房中睡到了大天亮,阳光照...追寻日出,找回自己 作者:Pastore Antonio
1535 浏览量